Pulsonix Vault
Evaluation Guide

2 Pulsonix Tutorial

Copyright Notice
Copyright ã WestDev Ltd. 2000-2022
Pulsonix is a Trademark of WestDev Ltd. All rights reserved. E&OE
Copyright in the whole and every part of this software and manual belongs to WestDev Ltd.
and may not be used, sold, transferred, copied or reproduced in whole or in part in any
manner or in any media to any person, without the prior written consent of WestDev Ltd. If
you use this manual you do so at your own risk and on the understanding that neither
WestDev Ltd. nor associated companies shall be liable for any loss or damage of any kind.
WestDev Ltd. does not warrant that the software package will function properly in every
hardware software environment.
Although WestDev Ltd. has tested the software and reviewed the documentation, WestDev
Ltd. makes no warranty or representation, either express or implied, with respect to this
software or documentation, their quality, performance, merchantability, or fitness for a
particular purpose. This software and documentation are licensed 'as is', and you the licensee,
by making use thereof, are assuming the entire risk as to their quality and performance.
In no event will WestDev Ltd. be liable for direct, indirect, special, incidental, or consequential
damage arising out of the use or inability to use the software or documentation, even if
advised of the possibility of such damages.
WestDev Ltd. reserves the right to alter, modify, correct and upgrade our software programs
and publications without notice and without incurring liability.
Microsoft, Windows, Windows NT and Intellimouse are either registered trademarks or
trademarks of Microsoft Corporation.
All other trademarks are acknowledged to their respective owners.
Pulsonix is a trading division 10 WestDev Ltd.
Printed in the UK. Issue date: 05/02/22 iss 2
Pulsonix
20 Miller Court
Severn Drive
Tewkesbury
Glos, GL20 8DN
United Kingdom
Phone +44 (0)1684 296 551
Email info@pulsonix.com
Web

www.pulsonix.com

Support Phone +44 (0)1684 296 570
Email support@pulsonix.com

Pulsonix Tutorial 3

Contents
CONTENTS ................................................................................................... 3
CHAPTER 1. GETTING STARTED ............................................................................ 4
Introduction to the Pulsonix Vault ......................................................................... 4
Introduction to the Tutorial .................................................................................. 4
Additional Help ................................................................................................... 4

CHAPTER 2. INSTALLING THE PULSONIX VAULT ........................................................... 5
Installing the Pulsonix Vault ................................................................................. 5
Signing In to the Vault......................................................................................... 6

CHAPTER 3. VAULT MANAGER OVERVIEW ................................................................. 7
Vault Manager Overview ...................................................................................... 7
Navigating the Vault Manager............................................................................... 7

CHAPTER 4. USING THE PULSONIX VAULT ................................................................ 9
Creating a new design using Vault items ................................................................ 9
Inserting Components from the Vault .................................................................. 10
Checking a design into the Vault ......................................................................... 15
Adding items to the Vault................................................................................... 16
Update Vault Design with Vault Part .................................................................... 19
Investigating items within the Vault .................................................................... 21
Creating a Search in the Vault ............................................................................ 22
Seeing the Audit History within the Vault ............................................................. 23
Additional Information ....................................................................................... 24

4 Pulsonix Tutorial

Chapter 1. Getting Started
Introduction to the Pulsonix Vault
The Pulsonix Vault is a revision/version control system which allows you to manage Pulsonix
data in a company defined methodology.
The Vault can be installed locally or on a company server and provides controlled user access
to a database of Pulsonix data that can be checked in/out, deleted and modified with full audit
history.

Introduction to the Tutorial
This tutorial is intended to familiarise you with the Pulsonix Vault features and its
methodology by working through a step by step tutorial. Using a supplied Vault demo, the
tutorial will show you how to setup, install and use the Pulsonix various elements within the
Pulsonix Vault.

Additional Help
Help is available in a number of formats; Online help available by pressing <F1> at any time
when using Pulsonix; by emailing us at support@pulsonix.com, or by calling us or your local
distributor. You will also find the Vault Users Guide installed as a PDF file, this is instantly
available from the Pulsonix Help menu and <Online Manuals>.
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Chapter 2. Installing the Pulsonix Vault
Installing the Pulsonix Vault
To install the Pulsonix Vault, you will need to run the Vault Server
Setup application from your Pulsonix Vault Admin installation folder.
If you are running a newer version of Windows, you may find the icon
on the right appear in your recently added applications.
You should now see the Vault Server Setup dialog.
Click the Install Demo Vault button to install the pre-populated Vault which will be used in
this tutorial.

Once you have pressed the Install Demo Vault button, you will then be presented with the
Vault Demo Setup dialog as below:

Click the Install Now button to complete the Vault Demo setup.
Note: If you already have a Postgres database running, press the Options button to set your
existing database credentials.
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Signing In to the Vault
The final stage of installing the Pulsonix Vault is to activate it from within Pulsonix.
In Pulsonix, go to the Setup menu, click Vault, you will now see the Vault Setup – Sign In
dialog. From here, enter the User Name: ‘admin’ and Password: ‘password’ from the
Sign In tab, click Test to verify the connection, click OK to close the dialog once the
connection is verified and click OK again to close the Vault Setup – Sign In dialog.

You are now ready to start using the Vault functionality.
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Chapter 3. Vault Manager Overview
Vault Manager Overview
To open the Vault Manager, click the File menu and select Vault Manager. Within this
dialog you can search and investigate all the items that are saved within your Pulsonix Vault.
The picture below shows you the major facets that are within the Vault Manager.

Navigating the Vault Manager
Upon opening the Vault Manager, you will be presented with a blank dialog, as shown below,
to navigate the Vault manager you can expand the folders by selecting the ‘+’ symbol.
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Open the Design Content folder to show the content of the LED Display project. Within this
folder you will see a Schematic Block, Schematic Design and a PCB Design.
Selecting the Schematic Design, you will now see specific details relating to the Schematic
Design in the grid below.

u Changing the Item Details
Using the Item Details dropdown arrow, you can choose which information of the item you
wish to inspect. You can choose from Audit Trial (an audit history of the selected item),
Where Used (informs you where the Item is used, e.g. which Designs a selected Parts is
used in) and Refers To (informs you which items are used in the selected item e.g. Which
Parts are used in the selected design).

u Changing the displayed Revision
Using the Revision dropdown arrow, you can select which revision of the selected item will be
displayed in the grid. You can choose from the <Latest revision> (Default setting), <All
Revisions>, alternatively you can select a specific revision of an item.
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Chapter 4. Using the Pulsonix Vault
Creating a new design using Vault items
u To start a new Schematic design
On the File menu, click New and Schematic Design from the Design tab.

On the Technology: drop down list, click on the small 'down' arrow to reveal the list, select
Default (White - Imperial), by default this will be shown in the list with a blue background
to indicate it has come from your Vault.
On the Profile File: drop down list, click on the small 'down' arrow, select the A4-Landscape
profile file to add an A4 drawing blank, by default this will be shown in the list with a blue
background to indicate it has come from your Vault. More detail about Technology files and
Profile files is available in the online Help. For now, we will progress on to adding Components
to the design.
Click the OK button to start a new Schematic design.
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Your Pulsonix window will look like
this to the left. To view the whole
page, you may need to click <A>
on the keyboard.
If you wish to start with a black
background, either change it in
Colours, shortcut <C> and the
Others page or start the new
design with the Default (Black –
Imperial) Technology file.

Inserting Components from the Vault
u To Insert a Component
Select the Insert Component button on the SCM toolbar (docked left side) shown circled
below, or use the Insert Component option from the Insert menu. You can also use the
shortcut key Shift-C

You are presented with the Insert Component dialog:
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On the initial start-up, the Look In: will default to [All Libraries], change the this to be [Vault
Only], this will then allow you to only place Parts that have come from your Vault.
For the purpose of this tutorial, we will now make a portion of the LED Display example circuit
which can be found in your Vault. As shown below:

The first Part to add is the CMOS Counter/Divider. One of the quickest ways to select the Part
you want is to simply type the first letter(s) of its name.
In the Part box, Type C, you will now see the CMOS Counter (CD4017BE) is filtered in the list,
now click the Add button to insert it into the design.
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u Adding Diodes
We will now add the Diodes to our design. Click on the Insert Component button again.
Type 1N148 into the Part field. Click the Add button to add the Part to your design. We want
to add 8 instances of this Part.

Use the ‘R’ key on your
keyboard to rotate a
component during
placement.
After you have inserted
the symbol, clicking
escape on your keyboard
will take you back to the
Insert Component Dialog.
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Hint: Using the context menu during insert, you can select Insert Multiple Items, this will
allow you to insert 7 instances in one process.

u Add First Resistor
We will now add the first resistor to our design. Click on the Insert Component button
again.
From the drop-down arrow on the Part Field, select R 0.25W 5% MCF 10K and add it to your
design as shown in the diagram below.
Use the ‘R’ key on your keyboard to rotate a
component during placement.
After you have inserted the symbol, clicking
escape on your keyboard will take you back to
the Insert Component Dialog.

u Add Second Resistor
We now need to add the second resistor that has a different resistance value. Click on the
Insert Component button again.
From the drop-down arrow on the Part Field, select R 0.25W 5% MCF 330 and add it to your
design as shown in the diagram below.

u Add Transistor
The final Part we need to add the design is the Transistor. Click on the Insert Component
button again.
Type 2N222 into the Part field. Click the Add button to add the Part to your design. Your
design should now look something similar to the image below.
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u Adding Signal References
We now need to add Signal References to our Design. To do this, click Signal Reference,
from the Insert Menu.
Ensure the Look In: is set to [Vault Only]. Select the +5V Symbol from the Symbol dropdown list and using the Add button, insert the symbol above the Transistor in your design.
Upon adding the symbol into the design, a dialog will appear allowing you to define the Net on
the Signal, leave it as +5V and click the Use for all net type button.
Once you have inserted the +5V Signal Reference, press the escape key on your keyboard,
you will now see the Insert Signal Reference dialog, from here, select the GND symbol
from the Symbol list and add it to your design below R1.
Your design should now look like the image below:

u Adding connections to your design
To finish this example circuit, we need to add connections to this design.
To insert a connection, you can double click on a Symbol’s pin which will invoke the insert
connection option. Alternatively, you can use the Insert Connection mode, available from
the Insert menu.
Route the Schematic so it looks similar to the example below:
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Our example circuit is now finished, you can choose to click the Save option from the File
menu if you would like to keep a local copy of the file prior to checking it into the Vault. If you
do not choose to save the design, the Vault will automatically create a save version as you
check it into the Vault for the first time.

Checking a design into the Vault
With the example design we have just created open, click the File menu and select Check
into Vault.
You will now be presented with the Check Into Vault dialog.

In Name: type ‘Tutorial Design’. Next you need to define where the design will be saved to,
set the Vault Folder to be \Design Content\Tutorial Design. Finally, add a Check In Note for
the design.
When checked, the Close item after Check In option will close the design automatically for
you.
Press the OK button to check the design into your Vault.
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Adding items to the Vault
The next section of this tutorial will look at how to add new items to the Vault for the first
time.
We will look to add a Surface Mount resistor to the Vault as we do not currently have one in
the demo.
As there is already a resistor Schematic Symbol in the Vault, we will only need to add a
Footprint and Part to the Vault.

u Add SM0605 Footprint to Vault
From within Pulsonix, go to Setup, Libraries and click the PCB Footprints tab.
Clicking the drop-down arrow, open the SM library.
From within the Contents, select the footprint SM0603 and click the Check In… button.

From within the Check Into Vault dialog, select the chosen Vault Folder and enter a Check
In Note for the Footprint. Press the OK button to check the Footprint into the Vault.
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Now the Footprint is in the Vault, we can look to create a Part, referencing the Schematic
Symbol and PCB footprint which is form the Vault.

u Create New Part to include Vault Items
From within the Library Manager, click the Parts Tab, select the Resistor Library from the
drop-down arrow and click the New button.

Within the New Part Dialog, type the name for the new Part, this will be R 0.25W 10K. Now
you type a Description for the Part, its Name Stem and Pin Count.
Next, in the PCB View section, we need to assign a Footprint to the Part. Using the dropdown arrow, search for the SM0603 footprint we added to the Vault.
Finally, in the Schematics View, search for the Symbol R which is in the Vault.
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u Adding Attributes to the Part
From within the Part Editor, we can now add Attributes to the Part, these will then be
searchable from within the Vault should we need to search for them.
Type 10K in the Value field and Resistor in the Category field.
If you wish to add more
attributes, go to the
Insert menu and click
Attributes.

u Check Part into Vault
Now the Part is complete, we now need to check it into the Vault. From the File menu, click
Check Into Vault.
Select the chosen Vault Folder and enter a Check In Note for the Part.
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Update Vault Design with Vault Part
u Update Tutorial Design with R 0.25W 10K Resistor
We will now check the Tutorial Design out of the Vault and replace the now deemed ‘obsolete’
10K Carbon Film resistor with the more modern Surface Mount version we just created.
From within the Vault Manager, open the Tutorial Design folder, select the Tutorial
Schematic Design and click the Check Out… button. Add a note in the Check Out Note
section and press OK.

Once checked out, you will notice the Tutorial Design has changed its background colour in
the Vault Manager. This indicates the item has been checked out by a user. Changing the
Item Details: to display the Audit Trail allows you to see the action that has occurred and
by whom.
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u Replace Resistor in the Tutorial Design
Select the component R1 in your design, right click and select Replace Part from the Context
Menu.
From within the Change Part dialog, click the change button and select the R 0.25W 10K
Resistor we added to the Vault earlier in this tutorial. Click the Replace button to update the
design with the new Part.
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We can now check the design back into the Vault. From the File menu, click Check Into
Vault, add a Check In Note and press OK to finish.

Investigating items within the Vault
Now that we have more than one revision of the Tutorial Design in the Vault, we can start to
see an audit history of what actions have happened and by whom.
If we change the Item Details: to Refers To, and the Revision: to <Latest Revision>, we
will see the design now contains the new resistor we have added to replace the ‘obsolete’
Carbon Film resistor.

We now need to if the ‘obsolete’ Carbon Film resistor is used in any other designs and will
then be able to update those designs with the new Surface Mount version accordingly.

u Locate Carbon Film Resistor
To locate the Carbon Film Resistor we can change the Design Revision: to be 1.0, as we
know this design revision uses the old resistor. Select the Resistor in the Item Details section,
right click and select Show ‘Where Used’ from the Context Menu.

22 Pulsonix Tutorial

The Vault Manager will now ‘jump’ to the Item Details table for the Resistor Part and list all
the designs it is used in.
We can see that the Carbon Film resistor is also used in the LED Display Schematic and PCB
Designs. These would need to be checked out and updated before the next iteration is
produced.

Creating a Search in the Vault
We will now look to create a Search from within the Pulsonix Vault, these can be saved for
easy access in future.
From within the Vault Manager, Click the Search… button.
You will now be within the Search in Vault dialog, change the Find: to be Schematic
Design and press the Apply button.
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Now click the Save As button, and type Vault Schematic Designs for the name of your
search and press Save.

Going back to the Vault Manager, you will now see the Search is available from the drop-down
arrow for ease of access and use in the future.
Note: You could create
quick searches to show All
items currently checked out
of the Vault, or All items
checked of the Vault by
user x.

Seeing the Audit History within the Vault
When you wish to see recent activity within the Vault, you can use the Audit Trail tab to see
what actions have occurred, when they occurred and by whom.
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u Create Audit Trail Query
Enable the Filter By: section, tick the Latest: box and enter 10 in the value section. Now
select the entries radial button.
Tick the Where: box and select Action Type, Equal to and Added in the drop-down boxes.
Now press the Apply button to see the results of your query.

From this search, we can see two items have been added to the Vault, the time and date they
were added, by whom, what the item was and the note that accompanied the check in.

This completes our brief run-through of the Pulsonix Vault.

Additional Information
There are more aspects to Pulsonix Vault which are not covered in this document. Further
information can be obtained in the Online Help using the <F1> key at any time, or from the
Pulsonix Users Guide supplied as a PDF file under the Help menu and Online Manuals or on
our web site.
While evaluating Pulsonix or once you’ve purchased it, technical support is provided in the
form of telephone support from our office or from your local sales office, or by email.
Head office support +44 (0)1684 296 570
Head office email support support@pulsonix.com
Web site www.pulsonix.com

