Pulsonix User Forum

Technical advice from Pulsonix engineers and the wider community.

Username:
Password:
Save Password
Forgot your Password?

 All Forums
 Help with using Pulsonix
 Manufacturing outputs
 [Solved] User Report Attributes
Author Previous Topic Topic Next Topic  

AdBemt

Netherlands
13 Posts

Posted - 14 Mar 2018 :  19:57:02  Show Profile  Visit AdBemt's Homepage  Reply with Quote
One of the powerful features of Pulsonix is placing user reports in both schematic and Layout designs.

It is also possible to assign Attributes to this User Report Symbols.

Is there a way to read the attribute value assigned to this User Report Symbol and use it in the report itself?

Edited by - AdBemt on 16 Mar 2018 11:13:47

steve

United Kingdom
316 Posts

Posted - 15 Mar 2018 :  09:36:52  Show Profile  Visit steve's Homepage  Reply with Quote
Could an example design and report be provided to support at support@pulsonix.com, with an explanation on what is wanted to be achieved and why?

Pulsonix Assistance
Go to Top of Page

steve

United Kingdom
316 Posts

Posted - 16 Mar 2018 :  10:43:43  Show Profile  Visit steve's Homepage  Reply with Quote
Your provided example has been modified and returned to you. The report will look to see if it is being run using Utilities – Update All User reports and extract the attribute value from themselves then refresh the reports drawn.

If it recognises that the report is going to a text file, it will prompt for the attribute value instead.

Important: After modifying any drawn report format for any report inserted in a design, always remember to Reload the report by selecting the drawn report and use Reload User Report command from the context menu.

Pulsonix Assistance
Go to Top of Page

AdBemt

Netherlands
13 Posts

Posted - 16 Mar 2018 :  11:13:04  Show Profile  Visit AdBemt's Homepage  Reply with Quote
Hi Steve,

This is excacly what I need.

Thank you verry much!
Go to Top of Page
  Previous Topic Topic Next Topic  
Jump To: