Pulsonix User Forum

Technical advice from Pulsonix engineers and the wider community.

Username:
Password:
Save Password
Forgot your Password?

 All Forums
 Help with using Pulsonix
 Libraries
 Step models not showing up on PCB
Author Previous Topic Topic Next Topic  

trayres

USA
15 Posts

Posted - 26 Mar 2015 :  05:01:42  Show Profile  Reply with Quote
I've created a schematic symbol, and a footprint with a STEP filename attribute that is set to a filename within the STEP Model folder.

When I create a part, the STEP model shows up perfectly (after some rotations/x-y alignment)! However when I drop my schematic symbol down, update a PCB with this new component, and then view the board model, I don't see the STEP file.

I noticed that when I checked the Folder settings for STEP Models, it says 0 files are found (even though I can plainly see the file).

I did try restarting Pulsonix. Thoughts?

Thanks,
-Travis

steve

United Kingdom
316 Posts

Posted - 26 Mar 2015 :  10:28:33  Show Profile  Visit steve's Homepage  Reply with Quote
Which version/build of PSX are you using?

Firstly, if you can see the STEP model in the folder in File Explorer, just double check your mapping to the correct folder in Folders as they should appear there, if the mapping is enabled.

Secondly, after update, are the STEP attributes still there?

Send your symbol, footprint, part and model to support@pulsonix.com

Pulsonix Assistance
Go to Top of Page

trayres

USA
15 Posts

Posted - 28 Mar 2015 :  02:17:32  Show Profile  Reply with Quote
If I go to View -> 3DView, the Coilcraft models are incorrect but U1 is correct.

When I go to Output -> STEP -> Preview, the Coilcraft models are correct but U1 is incorrect.

I couldn't see the file from the Pulsonix folder because it was named .STEP, but the folder expects .STP - even after fixing that the issue remains.

I'll gather up all the pieces and shoot them to you, thanks
:)
Go to Top of Page

jameshead

United Kingdom
85 Posts

Posted - 30 Mar 2015 :  09:03:50  Show Profile  Visit jameshead's Homepage  Reply with Quote
I had a quick look and there looks like there's something peculiar in Pulsonix here that looks like a bug.

In my Tools > Options > File Extentions I have:
.stp;.step
under STEP Models, so Pulsonix should recognise both extensions.

In Pulsonix 8.5 in the footprint editor:

1) Tools > Position STEP Model will only show .stp files and not .step files that are in my "Step" folder.

2) Edit Attributes of Library Items will also only show .stp files under the <STEP Filename> attribute when you click the dropdown button.

In my Library I have a couple of footprints with the extension .step that were created in Pulsonix 8.0 where you typed in the STEP file name manually. If you edit these footprints and use Tools > Position STEP Model the STEP file name that already exists for these disappears. View > View STEP shows the correct .step footprint though.
Go to Top of Page

psxforum

United Kingdom
61 Posts

Posted - 30 Mar 2015 :  09:09:54  Show Profile  Visit psxforum's Homepage  Reply with Quote
In this case Travis is using files all with .STP extension (we've now received his files to examine), but we will certainly investigate that issue with not obeying the 'dual' file extensions.

David.
Go to Top of Page

Chris

Netherlands
40 Posts

Posted - 07 Mar 2016 :  08:46:14  Show Profile  Visit Chris's Homepage  Reply with Quote
I think i have the same problem. I attached a step model to a footprint. When i do a Step Output and preview the part i see the step model, but when i do a 3D view i only see a black rectangle with some thickness.
What can i do to correct this problem ?


Edited by - Chris on 07 Mar 2016 09:06:14
Go to Top of Page

uslimey

USA
12 Posts

Posted - 07 Apr 2017 :  22:13:35  Show Profile  Visit uslimey's Homepage  Reply with Quote
Has this very been resolved yet?...

The help files are not very helpful with regard to Step Files and 3D views... I played around for a while today... I added a step file to the library... Added and positioned the step file in the footprint... I even added the attributes for Step File Name, Offset and Rotation... In my PCB if I look at the attributes, the three step file attributes show up correctly... If I do a 3D view of the board I just get generic grey rectangles instead of the step file image... If I do an export to step, and preview, the export shows the correct image...

I am not sure if I am doing this correctly... It strikes me that a footprint could be generic to a number of parts... For example a dual row connector... There are loads of different parts that use the same footprint... That being the case, it would seem more appropriate for the step file be part of the Part not the Footprint. But... Even though you can add attributes (such as Step File name) to the Part, there doesn't appear to be an easy way of mating the step file with the footprint at the part level.

Another thing I noticed was that there didn't appear to be a method of adding a step file to the library in the library manager... It does appear in the library manager if you copy the file to the appropriate folder... But again, I am not sure if this is the correct way to do this..

Anyway, I would really appreciate some insight as to how this is supposed to be implemented.

Steve
Go to Top of Page

steve

United Kingdom
316 Posts

Posted - 10 Apr 2017 :  09:48:13  Show Profile  Visit steve's Homepage  Reply with Quote
STEP models positioned on a footprint are there to support preview and output of STEP, they are not there to support the 3D Viewer which uses component shapes defined by the 3D View library. So to be clear, STEP models cannot be seen in the 3D Viewer, which is why this is not stated within Help.

In the 3D View (view menu), if there is not a 3D View shape defined within the 3D View library, then a 2mm high block will be formed from the Body Area on the footprint, if no area exists then from a rectangular bounding box calculated by the system around all the footprint elements. If component height is present on the footprint or above on the Part then this will be used to fashion the height of the shape.

The Position STEP Model option on the Tools menu in Footprint Edit, adds the three attributes to the footprint with the values when positioning the model, there is no need to manually add them, unless not using that tool.

Indeed the generic use of a footprint is sensible, however a STEP model can only be directly attached to a footprint.

There is not an 'Import' for STEP models into a library via Library manager as the library is a list of files from mapped folders, rather than a library file of held items.

The STEP model file extension has to be STP to be seen.

Pulsonix Assistance
Go to Top of Page
  Previous Topic Topic Next Topic  
Jump To: