Pulsonix User Forum

Technical advice from Pulsonix engineers and the wider community.

Username:
Password:
Save Password
Forgot your Password?

 All Forums
 Help with using Pulsonix
 Libraries
 Custom Pads....
Author Previous Topic Topic Next Topic  

uslimey

USA
11 Posts

Posted - 08 Mar 2017 :  16:46:52  Show Profile  Visit uslimey's Homepage  Reply with Quote
I recently transitioned from Easy PC to Pulsonix... One of the main reasons was te be able to define custom pad shapes which was a real bear with Easy PC.... So, here's todays problem... My interposer pad comprises of a relatively large, round, surface mount pad, coupled with a small, offset via... I was able to define this by defining the via'd section with the <Default Shape> layer, and the surface mount part defined with as TOP layer... This was great... It appeared to do everything I need... It put a large pad on the Top and small pads on all other layers... I say, 'this was great' because it was until I mirrored my part in my assembly... Everything flipped to the other side except the surface mount pad...

Any help would be appreciated!

psxforum

United Kingdom
61 Posts

Posted - 09 Mar 2017 :  09:03:08  Show Profile  Visit psxforum's Homepage  Reply with Quote
If you go to Setup, Design Settings, General, there is a checkbox under Pad Exceptions called "Mirror With Component". From your description, I suspect that this is not checked, which is why it does not take your Exception pad shapes over to the back of the board when you mirror the component.
Go to Top of Page

uslimey

USA
11 Posts

Posted - 09 Mar 2017 :  15:12:18  Show Profile  Visit uslimey's Homepage  Reply with Quote
Thanks, that worked... However, it highlighted another issue...

For some reason , despite the silkscreen and surface mount parts of the pads being on the underside, the online DRC thinks the component is on the top side of the board...

Moreover, if you make through hole and bottom layer non selectable, the component does dim, however, it is still selectable.

I am trying to place decoupling caps as close to my power pins as possible... the decoupling caps are on the top side... I did disable the DRC but can't seem to find away of stopping the random selection of my component.
Go to Top of Page
  Previous Topic Topic Next Topic  
Jump To: