Pulsonix User Forum

Technical advice from Pulsonix engineers and the wider community.

Username:
Password:
Save Password
Forgot your Password?

 All Forums
 Help with using Pulsonix
 PCB Design
 Exposed Pad
Author Previous Topic Topic Next Topic  

Chris

Netherlands
40 Posts

Posted - 04 Feb 2017 :  12:47:15  Show Profile  Visit Chris's Homepage  Reply with Quote
I have made a footprint that has an exposed pad. In the schematic this pad has a pin that is associated with it.
When making the footprint i also added 4 via's in the exposed pad. This 4 via's have to be part of the same net as the exposed pad. When i connect the exposed pad in the schematic to the GND net and translate to pcb the exposed pad is connected to GND but the via's are not and for this reason i have design rule errors and the via's won't connect to the ground plane on the bottom layer.
I can connect the via's manually to the gnd net , but when i have 50 ic's in a design i have to do that 200 times.
What do i have to do to make that the via's are automaticly connected to the net from the exposed pad ?

Image Insert:

74.33 KB

Image Insert:

78.39 KB

Olaf

Germany
5 Posts

Posted - 04 Feb 2017 :  20:11:26  Show Profile  Reply with Quote
You can do this in the Footprint Editor. Select the exposed pad and the vias, right mouse click, then select "Add To Net" in the context menu. Pulsonix suggests the pin number of the exposed pad as the net name. This is only a dummy net name, the real net name in the design will be used.
After reloading the footprint in the design, errors should disappear and vias should be connected to the ground plane.
Go to Top of Page

Chris

Netherlands
40 Posts

Posted - 05 Feb 2017 :  08:52:32  Show Profile  Visit Chris's Homepage  Reply with Quote
Thanks, it works !!!
Go to Top of Page
  Previous Topic Topic Next Topic  
Jump To: